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CHAPTER 16 GANTT CHARTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Gantt charts are graphical representations of task-based projects.  

The tasks in a Gantt chart are both listed in a tabular format and 
displayed graphically as task bars, reflecting their duration. By 
linking related tasks, Visio can automatically adjust the timeline 
when tasks are delayed or completed before schedule. 

Hence, Gantt charts are the ideal tool to use if you are responsible 
for scheduling a project and tracking the duration of each of the 
tasks in the project to ensure the project is completed on time. 

In this session you will: 

 gain an understanding of Gantt charts 

 gain an understanding of Gantt chart options 

 learn how to create a Gantt chart 

 learn how to complete task details 

 learn how to create subtasks 

 learn how to link and unlink tasks 

 learn how to add and delete tasks 

 learn how to display and hide columns 

 learn how to format task bars 

 learn how to navigate a Gantt chart 

 learn how to export Gantt chart data 

 learn how to import data into a Gantt chart 

 learn how to print Gantt charts. 

INFOCUS 
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UNDERSTANDING GANTT CHARTS 
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Projects usually comprise multiple tasks. When 
you manage a project it can be difficult to track 
the tasks, their relationships, duration and status. 
A change in one task can affect the progression 

of a project and it is therefore important to have an 
overview of that project. Gantt charts are bar 
charts that depict activities in a project, their 
duration and their interrelationships. 

 The individual tasks are listed in the Task Name column. 

 A task is automatically formatted as bold when a task below it is indented. The bolding 
indicates that the task is a summary task and the indented tasks below it are subtasks of the 
summary task. Note that you cannot edit the duration of a summary task, only its subtasks. 

 The Start date determines the start position of the task bar. 

 The Finish date determines the end position of the task bar. 

 The Duration of a task determines the length of the task bar. You can either enter the 
Duration or let Visio calculate it by typing a Start and Finish date. Type the Duration as a 
number followed by w for weeks, d for days, h for hours, or m for minutes (for example, 3d for 
3 days).  

A task with a duration value of zero is a milestone (see task 8 Go to Airport above). 

 The % Complete indicates the progress of a task. The value is highlighted in the task bar to 
give additional graphical information. This column may not be showing by default, but can be 
added in manually. 

 The percentage complete is reflected in the task bar by a proportion of the task bar appearing 
in a different colour, see tasks 1 and 2 above. 

 Linked tasks are connected by connector lines. By connecting tasks, if the end date of one 
task changes, the connected tasks will automatically adjust to reflect the impact on the 
progress of the project. 

 Each task is represented graphically by a task bar. This makes it much easier to gauge the 
progress of a project. 
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GANTT CHART OPTIONS 
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When you are creating a new Gantt chart, there 
are a number of options that you need to select 
to determine the level of detail in the resulting 
chart. These options control the size of the chart, 

duration, duration format and the date range. While 
they can be changed after you have created the 
chart, you will finish your chart much earlier if you 
plan the layout first. 

 The Number of tasks option is only available when you are first creating a Gantt chart. 
Once this dialog box has been activated and the Gantt chart created, you cannot create 
additional tasks by using this option. Instead, you must either click on New  or drag the 

Row shape from the Shapes window to add extra tasks. 

 The Format determines the way in which the values will display in the Duration column of 
the Gantt chart. Durations are displayed as w for weeks, d for days, h for hours, and m for 
minutes (preceded by the number of those units). 

 The Timescale range determines the period of time displayed in the Gantt chart. The start 
time and finish time fields are only available if Hours has been selected in Minor units. 

 The Time units determine the level of detail where the task bars are displayed on the Gantt 
chart. In the Gantt chart, there are two levels of headings where the task bars are displayed. 
The top heading is determined by the Major units selected in the dialog box and the lower 
headings are determined by the Minor units selected. 
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CREATING A GANTT CHART 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

Before starting this exercise ensure 
no files are open in Visio... 

 Click on the File tab, click on 
Schedule under Template 
Categories, click on Gantt 
Chart and then click on 
[Create] 

The Gantt Chart Options 
dialog box will open letting 
you set the basic setup 
options for your chart. These 
options can be altered later... 

 Type 7 in Number of tasks 

The duration of the project 
will be a couple of weeks so 
you won’t need to change the 
default settings in Duration 
options and Time units. But 
let’s assume the project will 
start next April... 

 Click on the drop arrow for 
Start date in Timescale 
range to display a calendar 
for the current month 

 Click on the right arrow  

until April next year appears 

 Click on a Monday 

 Repeat steps 3 and 5 to 
change Finish date to the 
Wednesday two-and-a half 
weeks later 

 Click on [OK] to create the 
Gantt chart 

 

For Your Reference… 

To create a new Gantt chart: 

1. Select File > New > Schedule > Gantt 
Chart  

2. Select the required options  

3. Click on [OK] 

Handy to Know… 

 If you need to change the start or finish date 
of the project detailed in a Gantt chart, open 
the Gantt Chart Options dialog box by 
clicking on Chart Options  in the Manage 

group on the Gantt Chart tab. 

1 

6 

Visio includes a Gantt Chart template that 
enables you to create a visual representation of 
the activities in a project along with their duration. 
Because tasks can be linked to each other, the 

Gantt chart will automatically adjust if any tasks are 
delayed. You can then see the impact on the 
overall finish date of the project and take 
appropriate action if necessary. 

7 
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COMPLETING TASK DETAILS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the 

previous file or open V515 
Gantt Charts_1.vsd... 

 Zoom to 100%, then click 
on Task 1 in the Task 
Name column to select it 

 Type Research Holiday 
Locations, then click on 
the Finish date for this 
task 

As the Start date for the 
first task is the date when 
the project starts, you 
won’t need to change it... 

 Type a date two days 
after the Start date (we’ve 
typed 13/04/11 in our 
sample), then click on the 
Duration for this task 

The Duration will calculate 
automatically from the 
Start and Finish dates and 
the task bar will extend to  
3 days... 

 Complete the project 
details as shown including 
Task Names, and 
appropriate Start dates 
and Finish dates 

The task bars will appear 
in your chart based on the 
dates and durations you 
specify 

 

For Your Reference… 

To complete task details: 

1. Click on the task field to be edited 

2. Type the required value 

Handy to Know… 

 If you know the duration of a task, you can 
either type a value in Duration or drag the 
blue handle on the task bar to the desired 
date. Visio will calculate the Finish date. 

 To create a Milestone, or key date in a 
project, add a task with a Duration of zero. 

1 

2 

When you create a new Gantt chart using the 
Gantt Chart Options dialog box, Visio displays 
the specified number of tasks each with a default 
name, start date and duration. You can quickly 

name each task, adjust their individual start and 
finish dates, and indicate the expected duration for 
each task. The task bars in the chart will update to 
reflect your changes. 

3 
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CREATING SUBTASKS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
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e
 Continue using the previous 

file or open the file V515 Gantt 
Charts_2.vsd... 

 Click on the Gantt Chart tab to 
open it 

This contextual tab contains all 
commands pertinent to Gantt 
charts… 

 Click on the Book Tickets 
task to select it 

You can select multiple tasks, 

if desired, by pressing  

and clicking on each task… 

 Click on Indent  in the 

Tasks group 

The task will be demoted 
(indented) to a subtask. The 
task immediately above the 
subtask will be bolded as Visio 
assumes this is the summary 
task... 

 Repeat step 3 to indent the 
Pay Agent task 

Both of these tasks are now 
subtasks of the Contact Travel 
Agent task. 

The formatting of the summary 
task’s task bar will change to 
include triangle symbols at the 
start and end of the bar 

 

For Your Reference… 

To create subtasks: 

1. Select the task/s to demote 

2. Click on Indent  in the Tasks group on the 

Gantt Chart tab 

Handy to Know… 

 If you want to remove the subtask property 
from a task, select the task/s and click on 
Outdent . 

 The subtasks determine the Duration of the 
summary task. As a result of this, you cannot 
alter the Duration of a summary task (hence 
the bold formatting), only its subtasks. 

2 

3 

If you have a task in a project that comprises a 
number of other tasks, then you can break down 
the ‘parent’ task into subtasks and thereby track 
each individual aspect of the parent task. When 

you identify a task as being a subtask, the parent 
task is referred to as a summary task and it is 
formatted bold in the Gantt chart to indicate its 
status. The summary task and subtasks are linked. 

4 
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LINKING AND UNLINKING TASKS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il

e
 Continue using the previous 

file or open the file V515 Gantt 
Charts_3.vsd... 

 Click on the first task bar in the 
Gantt chart to select it 

 Press  and click on the 

Book Tickets task bar 

You cannot book the tickets 
before you’ve decided where 
to go for your holiday... 

 Click on Link  in the Tasks 

group 

 Press  to see the link more 

clearly 

A connector will be drawn 
between the two linked tasks... 

 Select the two task bars again 

Unlinking tasks is also a 
simple process... 

 Click on Unlink  to remove 

the link 

The link will now disappear... 

 Complete the links as shown 

Note that you will have to link 
Book Tickets to each of the 
three tasks on April 18

th
 

individually 

 

For Your Reference… 

To link tasks: 

1. Select the tasks 

2. Click on Link  

To unlink tasks: 

1. Select the tasks 

2. Click on Unlink  

Handy to Know… 

 By default, links are drawn in an ‘S’ shape. 
These are referred to as S type connectors. 
You can change the style of the connectors. 
Right-click on a blank area of the page and 
select S Type Connectors to remove the 
tick. The connectors will appear as ‘L’ 
shaped links. 

4 

2 

You can illustrate a relationship between tasks by 
linking them. For instance, you would link tasks 
where one must be finished before the next task 
can start. By linking tasks, any change in a task’s 

start and finish details will automatically affect the 
start and finish details of all tasks that are 
subsequently linked. In a cascading effect, this may 
ultimately affect the completion date of the project. 

7 
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ADDING AND DELETING TASKS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
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 Continue using the previous 

file or open V515 Gantt 
Charts_4.vsd... 

 Click on the Pack Bag task, 
then click on New  in the 

Tasks group to insert a new 
task above this task 

 Type Go to Airport, then 
add a Start date five days 
after the Finish date for 
Pack Bag and a Duration 
of 0d 

This task should be the last 
one… 

 Click on the Go to Airport 
task, then drag it below the 
Pack Bag task 

You can add a new task by 
adding a Row shape… 

 Drag the Row shape onto 
the bottom of the last row of 
the Gantt chart 

If you drop the Row shape 
on top of another row, it will 
be inserted above it. By 
moving the pointer to below 
the last row, the new row 
will be inserted below it... 

 Release the mouse to add a 
new row 

 With the new row still 
selected, press  to 

delete it – you should now 
have 8 rows in total 

 

For Your Reference… 

To add a new task: 

1. Click on New  in the Tasks group on the 

Gantt Chart tab or drag the Row shape 
either onto or slightly below a task  

To delete a task: 

1. Click on the task name and press  

Handy to Know… 

 You can add extra tasks to the bottom of a 
Gantt chart by clicking on the edge of the 
chart and dragging down the bottom 
selection handle. Visio will automatically add 
new tasks to occupy the additional space. 

 You can delete a selected task by clicking on 
Delete  in the Tasks group. 

1 

2 

When you first activate the Gantt chart template, 
you are asked to indicate the number of tasks 
you require. Obviously this can be very difficult to 
get exactly right before you start entering the 

tasks. However, you are able to add and delete 
tasks at any time by using the commands on the 
Gantt Chart ribbon tab or the shapes provided in 
the Gantt Chart Shapes stencil. 

3 
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ADDING AND HIDING COLUMNS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a

m
e

 

F
il
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 Continue using the previous 

file or open V515 Gantt 
Charts_5.vsd... 

 Click on the Duration 
column heading  

You must select a column 
before you can add a new 
one. The new column will 
be inserted to the right of 
the selected one... 

 Click on Insert  in the 

Columns group to open the 
Insert Column dialog box 

 Click on [OK] to insert the 
% Complete column 

You can also add a column 
using a shape... 

 Drag the Column shape on 
top of the % Complete 
column   

 Release the mouse to open 
the Insert Column dialog 
box 

 Click on the drop arrow  

for Column type and click 
on Resource Names, then 
click on [OK] to insert the 
column 

 Click on the Resource 
Names column heading 
and press  to remove 

the column from the Gantt 
chart 

 

For Your Reference… 

To add a column: 

1. Click on a column heading 

2. Click on Insert  in the Columns group 

To hide a column: 

1. Select the column heading 

2. Press  or click on Hide  

Handy to Know… 

 When you press  to delete a column, you 

are actually just hiding it. If you display the 
column again, any data that you previously 
added to it will still appear in the column. 

1 

2 

When you create a new Gantt chart, four 
columns will display by default. These are Task 
Name, Start, Finish and Duration. If required, 
you can display additional predefined columns 

such as % Complete, Actual Duration or 
Resource Names. You can also display  
user-defined columns such as number, text or time 
columns.  

3 
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FORMATTING TASK BARS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Try This Yourself: 

S
a

m
e
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Continue using the 
previous file or open the 
file V515 Gantt 
Charts_6.vsd... 

 Click on Chart  Options 
 in the Manage group 

to open the Gantt Chart 
Options dialog box, 
then click on the Format 
tab  

These formatting 
options apply to the task 
bars, summary bars and 
milestones... 

 Click on the drop arrow 
 for Start shape 

under Task bars and 
click on Arrow Up 

 Click on the drop arrow 
 for Right label and 

click on Task Name 

 Click on the drop arrow 
 for Shape under 

Milestones and click on 
Star 

 Click on [OK] to apply 
the changes 

You might need to zoom 
in to see the changes  

 

For Your Reference… 

To format task bars: 

1. Click on Chart Options  

2. Click on the Format tab 

3. Select the required options 

4. Click on [OK] 

Handy to Know… 

 To change the fill colour of a selected task 
bar (or a summary bar or milestone), click on 
Fill  in the Shape group on the Home tab 

and click on the desired colour. 

 You can specify the formatting options when 
you first create a Gantt chart if you know 
what options you want to use. 

1 

5 

There are a number of different formats that you 
can apply to the task bars to customise them. 
You can change the colours of the task bars, 
apply a shape to the starts and ends of the task 

bars, and choose to include labels with the task 
bars (labels can make task bars more informative 
at a glance). You can also apply formatting to the 
milestones and summary bars. 
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NAVIGATING A GANTT CHART 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a
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F
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 Continue using the 

previous file or open V515 
Gantt Charts_7.vsd... 

 Click on the Pack Bag 
task to select it 

Let’s assume you can’t 
see this task bar in the 
task bar area... 

 Click on Scroll To Task 
 in the Navigation 

group 

The task bar will be 
brought into view... 

 Click on Previous  in 

the Navigation group 

This scrolls one time/date 
unit to the left... 

 Click on Go To Finish  

in the Navigation group 

This adjusts the drawing 
so that the final date is 
visible, but you might 
need to scroll across to 
see it 

 

For Your Reference… 

To navigate the task bars: 

1. Click on a task name and click on the Scroll 
To Task tool  in the Navigation group  

2. Click on Next , Previous , Go To Start 

, or Go To Finish   to move through the 

tasks  

Handy to Know… 

 Right-click on a task name and select Scroll 
To Task to quickly navigate to the task bar. 

 Right-click on a date/time field at the top of 
the task bar area and select one of the 
Scroll... options from the shortcut menu to 
quickly navigate the task bar area. 

1 

2 

Gantt charts invariably become very wide making 
it often impossible to clearly display all task bars 
simultaneously. Typically, the task bar area is 
kept at a manageable size and Visio provides 

tools that let you navigate quickly to task bars when 
you need to see them. 

4 
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EXPORTING FROM A GANTT CHART 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

S
a
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F
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 Continue using the previous 

file or open the file V515 Gantt 
Charts_8.vsd... 

 Click on the border of the 
Gantt chart to select it 

If you don’t select the chart 
before the next step, Visio will 
automatically select it and 
display a message asking you 
whether or not you want to 
export it… 

 Click on Export Data  in the 

Manage group to open the 
Export Project Data Wizard  

You will now be led through a 
step-by-step process to export 
the data... 

 Click on Text File in Export 
my project data into... then 
click on [Next] 

 Click on [Browse], then select 
the course files folder as the 
location in which to save the 
file 

 Type Holiday Project in File 
name, then click on [Save] 

 Click on [Next], then click on 
[Finish] 

You will be notified if the 
export is successful... 

 Click on [OK] 

 

For Your Reference… 

To export data: 

1. Click on Export Data  in the Manage 

group on the Gantt Chart tab 

2. Select the data format  

3. Browse to the desired folder location, type a 

file name and click on [Save] 

Handy to Know… 

 To export data from a Gantt chart directly to 
Microsoft Project, you must have Microsoft 
Project installed on your computer. 

 Microsoft uses the same terminology in Visio 
as it does in Project making it easy for users 
to move between the two applications. 

2 

5 

The ability to exchange data between Microsoft 
Visio and other applications is a valuable tool. 
You can export information from a Visio Gantt 
chart in a format compatible with Microsoft Excel 

or with other project management tools, such as 
Microsoft Project, enabling you to analyse and 
report on the information more thoroughly. 

6 
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IMPORTING DATA INTO A GANTT CHART 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Try This Yourself: 

Before starting this exercise ensure 
no files are open in Visio... 

 Select File > New > 
Schedule > Gantt Chart, 
then click on [Create] and 
then on [Cancel] to close the 
Gantt Chart Options dialog 
box 

This will open a blank drawing 
based on the Gantt Chart 
template... 

 Click on the Gantt Chart tab, 
then click on Import Data  

to open the Import Project 
Data Wizard dialog box 

 Ensure that Information 
that’s already stored in a 
file is selected, then click on 
[Next] 

 Select Text File from the list 
of formats, then click on 
[Next] 

 Click on [Browse], then 
double-click on V515 Gantt 
Charts_9.txt in the course 
files folder 

 Click on [Next] accepting the 
default values until the 
[Finish] button is activated 

 Click on [Finish] to complete 
the import and create the 
Gantt chart 

You can resize and format 
this like other Gantt charts 

 

For Your Reference… 

To import data into a Gantt chart: 

1. Open a blank Gantt chart, then click on 
Import Data  in the Manage group on the 

Gantt Chart tab 

2. Select the settings in each step as required 

3. Click on [Finish] 

Handy to Know… 

 You can import data from Microsoft Project 
and Microsoft Excel files to create Gantt 
charts, or you can use text files with a .txt or 

.csv file format. 

2 

If you have data relating to a project stored in 
another application but would like to create a 
presentation of that data using Visio, then you 
are able to do this by importing the data. The 

Import Project Data Wizard is designed to take 
data from files created in other applications and 
convert it into a drawing such as a Gantt chart or 
timeline. 

7 
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PRINTING GANTT CHARTS 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try This Yourself: 

O
p

e
n
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Before starting this 
exercise you MUST 
open V515 Gantt 
Charts_10.vsd... 

 Click on the Design tab, 
then click on Size  in 

the Page Setup group 
and select Fit to 
Drawing 

Before printing any file 
you should always check 
it in Print Preview… 

 Click on the File tab, 
click on Print, then click 
on Print Preview 

Currently, the chart will 
print on one page. Let’s 
print it over two sheets 
of paper to make it 
easier to read… 

 Click on Page Setup  

to open the Print Setup 
tab of the Page Setup 
dialog box 

 Click on Fit to under 
Print zoom, then type 2 
in sheet(s) across  

 Click on [OK] 

Now the Gantt chart will 
print over two pages… 

 Click on Print , click 

on [OK], then close 
Print Preview 

 

For Your Reference… 

To print a readable Gantt chart: 

1. Click on Size  in the Page Setup group 

and select Fit to Drawing (Design tab)  

2. Click on the dialog box launcher  for 
Page Setup and adjust Fit to 

3. Select File > Print > Print 

Handy to Know… 

You can access the Print Setup dialog box in 
three ways. 

 Click on Page Setup  in Print Preview. 

 Click on the dialog box launcher  for 
Page Setup on the Design tab. 

 Right-click on the page tab and select 
Page Setup. 

2 

Many Gantt charts are too wide to print clearly on 
one page. There are two steps involved in 
printing readable Gantt charts. Firstly, you should 
adjust the size of the drawing page so that it fits 

the Gantt chart details only (this will maximise the 
size of the printed chart data). You can then adjust 
the printer zoom so that the chart will print on the 
desired number of pages.  

5 


